題 如何在Chrome中停止從“http://”到“https://”的自動重定向


我在DNS設置中設置了一些古怪的東西,現在已經解決了。

剩下的問題是chrome緩存了錯誤的設置。

具體來說,使用Chrome時 http://3rdrevolution.com 現在重定向到 https://3rdrevolution.com (裸域),無效/支持。 http://3rdrevolution.com  應該 重定向到 http://www.3rdrevolution.com 然後強迫 https://www.3rdrevolution.com

但是在少數幾個瀏覽器(包括我的瀏覽器)中,由於一些時髦的Chrome緩存,這種情況不會發生。我試著去“隱私 - >清除緩存”但它沒有效果。


265
2018-03-13 17:40


起源


檢查你的插件(如無處不在的SSL),你試過刪除(shift + del)嗎?嘗試使用 google.com/ncr 而不是google.xx。 - malakrsnaslava
可能重複 如何讓Chrome停止緩存重定向? - Ulrich Schwarz


答案:


Anon對STS是正確的,但是有一種方法可以從集合中專門刪除你的域名。轉到chrome:// net-internals / #hsts。輸入 3rdrevolution.com 下 刪除域安全策略 然後按“刪除”按鈕。

現在轉到chrome:// settings / clearBrowserData,勾選方框 緩存的圖像和文件 然後按下按鈕 清晰的數據


394
2018-02-23 14:17



謝謝,我嘗試了其他一切,這最終工作=) - Tyrsius
這對我也有幫助!在內部開發並具有相同的重定向問題! - Marcello de Sales
伙計,這已經困擾了我多年,終於明白了,謝謝!可能需要注意的一點:如果您遇到問題的域是子域,則可能需要從“HSTS集合中刪除主域”,如果“包含STS的子域設置為true”。如果您在父域上運行查詢,您應該看到是否為相關域設置了該查詢。 - Pooch
在我清除瀏覽器緩存後,這對我有用。在鉻: 設置>顯示高級設置...>隱私>清除瀏覽數據...  資源 - nittyjee
從63.0.3239.132開始,這沒有任何作用。該規則似乎被忽略,甚至鏈接到localhost的自定義域現在也被重定向到https。令人討厭的因素,必須使用自簽名證書... - Daniel


我的問題來自於 .dev 域名,顯然最近註冊為通用頂級域名(gTLD),並提交給Chrome Canary。我發現了這個 最近貼文 當我搜索我的問題時,我遇到了。

如果您遇到同樣的問題,那麼最佳解決方案似乎是將您的域名更改為其他內容 .dev。文章建議 .test 有潛在的解決方案 .localhost 後來在路上(通過 這個提議)。


166
2017-09-18 16:21



這對我來說也是個問題。在我的本地開發機器上,我使用.dev已經將近10年了。我最近做了一次谷歌Chrome更新,它開始將我的所有網站重定向到https,我無法理解。從來沒有想過它會與.dev有關,然後我遇到了這個答案並將其改為.development並且一切都運行得很好......現在:-)。再次感謝! - conrad10781
完善!我不明白為什麼Chrome會做這樣的事情,因為我在本地有近30個.dev域名,所以非常煩人。希望這是一個非常非常好的理由。 - Pablo Ezequiel Leone
我安裝了wordpress,改變它的域可能是一個真正的頭痛。相同的主目錄名稱ect。還有其他方法嗎? - Rick Sanchez
這是因為谷歌買了 .dev 並且可能會開始使用它來製作公共網站。 - Hilton Shumway
FML ......因為這個原因,我幾乎放棄了我10年以上的網絡開發生涯。 #starbucksbarista - elbowlobstercowstand


https://www.3rdrevolution.com 發送 嚴格,運輸和安全 標題,以便通過https訪問它一次將使Chrome / Firefox等瀏覽器將http請求重定向到https,直到將來某個指定點。

正如另一個答案所說,一旦啟動就停止此操作的唯一方法是清除瀏覽器緩存(或等待瀏覽器使訂單失效)。


17
2017-10-19 19:58





刪除域名 在“HSTS”菜單下 鉻://網內部 是一個臨時解決方案。 通過HTTPS訪問此域後,它將再次包含在HSTS列表中。

基本上,要解決這個問題是必要的 禁用HTTP嚴格傳輸安全性 在網絡服務器上 3rdrevolution.com (IIS,Apache,nginx,...)。 對於nginx,編輯其HTTPS部分 nginx.conf 並為嚴格傳輸安全設置'max-age = 0':

server {
#...
        ssl on;
#...
        add_header Strict-Transport-Security "max-age=0;";
#...
}

更多信息:HTTP嚴格傳輸安全(HSTS)


13
2017-07-05 17:47



我無法使add_header方法起作用。 - Alex Barker
對我來說,服務器沒有發出HSTS標頭,所以這不是一個解決方案。據我所知,當我意外地使用https訪問時記錄了chrome,並創建了一個內部HSTS記錄,然後每次神秘地將我重定向到https。修復是使用chrome:net-internals中的刪除HSTS記錄。那裡也有一個方便的檢查員。 - rob
刪除HSTS記錄是一種臨時解決方案。在訪問https直到服務器發送“max-age = 0”後,您將一次又一次地獲取此記錄。 - user2285323


這可能有幾個原因,包括插件,但假設您沒有安裝任何插件,您可以執行以下操作:

設置/隱私/清除瀏覽數據...

選擇 剛開始的時候 在拉下來。

選擇:

  • 清除已保存的自動填充表單數據
  • 刪除Cookie和其他網站和插件數據
  • 清空緩存

選擇 清除瀏覽數據

這應該照顧它根據您以前的瀏覽進行任何自動填充。此外,它將刪除任何可能導致問題的cookie。


10
2018-05-08 16:57



對我來說問題是緩存。我能夠在firefox和Chrome隱身窗口中訪問我的http網站。該網站沒有cookie。 - ton.yeung
這對HSTS沒有的地方也有用。我只需要檢查“圖像和文件”複選框。 - dgig
這對我有用,而HSTS和其他解決方案卻沒有。 - AllisonC
這對我也有用。 - jcubic


除了清除所有cookie之外,一個不那麼激烈的選擇 設置>顯示高級設置>內容設置>所有Cookie和網站數據 然後搜索有問題的網站並清除僅限於那些網站的cookie。


4
2017-07-25 14:26



謝謝這完美的工作。我不知道為什麼Chrome會讓這個隱藏的功能......實際上,我可以猜到為什麼...... - ktec
這似乎不適用於當前的Chrome版本。 - Vylix


在幾天之前,我不小心打開了名為的Chrome選項:

  • 自動將一些系統信息和頁面內容髮送給Google,以幫助檢測危險的應用和網站
  • 保護您和您的設備免受危險場所的侵害

現在主要的問題是我們的子網站上的網站總是重定向 HTTP:// 至 https://開頭 和瀏覽器給了我一個錯誤:

“您的連接不是私密的。攻擊者可能會試圖從censored.censored.com竊取您的信息(例如,密碼,郵件或信用卡).NET :: ERR_CERT_COMMON_NAME_INVALID”

打開 鉻://設置/隱私 並轉動以前命名的Chrome選項,自動保護您的設備。希望這會對​​某人有所幫助。


3
2018-04-01 13:19



似乎沒有為我工作。 - Dave Burton


如果您在子域上遇到問題,那麼即使子域位於另一台服務器中,Nginx中的這一行也可能會導致問題,因為瀏覽器將緩存此信息。

add_header Strict-Transport-Security "max-age=31536000; includeSubdomains;";

所以刪除 includeSubdomains; 它使它工作。


2
2018-05-30 03:53





在Chrome 66中,很多內容都發生了變化 Settings 標籤

你可以去 chrome://settings/resetProfileSettings?origin=userclick 然後點擊重置。

這對我有用。


2
2018-02-27 19:33