題 下一個Firefox版本:如何*輕鬆*檢查擴展/附加兼容性?


題: 

我目前使用Firefox 3.6。在我安裝下一個版本的Firefox(此時是Firefox 4)之前,有沒有一種簡單的方法來檢查哪個版本 所有 我安裝的擴展程序/附加組件是否兼容?

背景:

我希望一鍵式解決方案,因為我  想先安裝FF4而不是看到其中一些不兼容,而且我  想檢查每個已安裝擴展的每個主頁,看看它們支持哪個版本。

也許存在'列出每個附加組件的最高兼容FF版本' 延期?我用谷歌搜索但找不到任何東西......

對於FF的任何未來版本,這個問題也是通用的,因為從FF 1到2,從2到3時我遇到了同樣的問題。那時候,我不介意擺弄和嘗試各種各樣的東西,現在我做。

編輯: 理想情況下,我應該能夠檢查某處的複選框以進行擴展(或Firefox本身 - > FF開發人員的提示)監視我的加載項是否兼容,並在它們出現後通知我(使用彈出窗口) ,所以我可以升級。雖然我猜這對統計數據很有好處,所以Mozilla提供了一個 龐大的兼容擴展列表 而對於普通用戶來說,如果我作為用戶可以更輕鬆地檢查我的內容,那會更有用 個人 情況。

編輯2: 似乎我對我的問題並不孤單:看 這個救生員的帖子


11
2018-04-04 12:19


起源


它不只是ansver。但它可能有用。如果擴展,沒有我不能生活,與Firefox的新版本不兼容,我修復了install.rdf及其工作中的兼容性。擴展真的是拉鍊。一些擴展更新非常慢。 - Mikhail Moskalev
技術答案是您檢查擴展使用的API對每個新版本中更改的API / ABI。很難,不知道怎麼做。 - tobylane


答案:


也許Firefox附加組件 它兼容嗎? 會幫助你(它幫助了我)。它只是將兼容性信息添加到已安裝的加載項列表中。


10
2018-04-04 14:16



似乎正是OP正在尋找的東西。我自己安裝了它。 - ale
確實,這就是我想要的。我看到答案日期是4月4日。似乎我沒有註意到你的答案(並且沒有充分理由就開始了賞金)。愚蠢的我 ! - Rabarberski
我想你也錯過了Add-on Compatibility Reporter,這是一個更好,更全面的解決方案。看到我的回答。 - harrymc
@harrymc:我沒有錯過附加兼容性記者。然而,它針對的是alpha和beta用戶,所以我沒有考慮它(即使在閱讀了描述之後) - Rabarberski
@Rabarberski:它適用於所有用戶。在測試附加組件的兼容性時,你 是 一個beta測試員。 - harrymc


或許你可以查看一下 附加兼容中心

這裡有一個報告列出了按受歡迎程度排序的所有已安裝加載項的95%的加載項。 (我會鏈接它,但沒有直接的URL。)


5
2018-04-04 13:18



確實,這就是您所尋找的點擊查看兼容性報告,然後查看詳細報告。 - Jeff F.
這確實需要我檢查列表中的每個加載項。還是太多的工作,對不起...... - Rabarberski


首先說一句:我建議在任何情況下等待FF 4.1,因為版本4.0非常不穩定。它經常流產,所以最後我才回到FF3。我相信新的Javascript引擎仍然存在問題。

現在解決您的問題:沒有確定的方法可以知道加載項是否與FF4兼容。即使它被FF4標記為不兼容和禁用,它實際上仍然可以完全兼容。你只需要試著看,最簡單的方法就是關掉支票。

強制Firefox擴展兼容性,版本檢查已關閉 about:config中 :右鍵單擊列表並選擇“新建”(如果已經存在,請先查看),然後選擇“布爾”。輸入名稱為'extensions.checkCompatibility'和值為'假'。 完成後,擴展程序將不再檢查它們是否與您運行的Firefox版本兼容。您可以隨時通過將其設置為“true”來重新啟用該檢查。

本文介紹了一種更好的方法,同時幫助社區。 在Firefox中測試和報告附加兼容性

一個安裝 附加兼容性報告器,它使您所有不兼容的擴展程序能夠測試它們是否仍然有效。如果您發現其中一個加載項似乎與以前版本的應用程序中的加載方式不同,只需打開加載項管理器並單擊該加載項旁邊的“兼容性”即可將報告發送到Mozilla的。您當然也可以報告擴展程序運行良好。


2
2018-04-07 10:14





你可以嘗試使用 Firefox便攜版。這樣,您可以查看Firefox 4及其與附加組件的兼容性,而無需卸載當前版本的Firefox。


0
2018-04-04 13:14



嗯,這需要我查看我已安裝的擴展程序,並在便攜版本中安裝它們中的每一個。太多麻煩了。 - Rabarberski


這不是一鍵式解決方案,但在我看來,它是最靈活的:我會將Firefox 4安裝在與Firefox 3不同的目錄中,然後製作配置文件的副本。您將使用舊版配置文件使用Firefox 3,使用新版本使用Firefox 4。 Firefox 4將在啟動後立即檢查附加兼容性。

優點:

  • Firefox 4本身將檢查兼容性
  • 您可以隨時返回Firefox 3
  • 可以等到所有擴展程序趕上或Firefox 4達到您滿意的程度,然後毫不費力地切換到新版本。

缺點:

  • 不是一鍵式解決方案
  • 增加磁盤空間(但通常不會出現問題,除非系統空間非常緊張,例如帶有小型SSD的上網本)

要製作配置文件的副本,只需在啟用配置文件管理器的情況下啟動Firefox 3(如果您不知道如何查看 Mozilla網站),然後創建一個新的配置文件。退出,打開存儲配置文件的文件夾(這取決於您使用的操作系統和特定版本),並將舊配置文件複製到新配置文件上。

如果您以前從未這樣做過,可以在大約10-15分鐘內完成操作。


0
2018-04-11 19:15





嘗試添加“兼容” https://addons.mozilla.org/en-US/firefox/addon/is-it-compatible/ 我沒試過,但這可能就是你要找的東西。


0
2018-04-11 20:40



的確,這就是我想要的! - Rabarberski
呃...這就是馬丁的建議 他的回答。 - ale


就像@Rabarberski一樣,我找到了 Add-on Compatibility Report for Firefox <release> 無法使我的工作流程保持清醒。至於 Is It Compatible? 自FF v30以來,它沒有經過驗證並停止工作。

我的臨時解決方案:我 備用 (快照)整個配置文件並保留以前的Firefox包。這讓我可以盲目更新(Mozilla方式),和 下坡 如果遇到麻煩,有限的麻煩,到之前的版本。 Firefox Portable 在Linux上不可用。

還有,這是 一個問題,要求提供有關該主題的更多信息 關於Mozilla的支持


0
2018-04-03 10:35





儘管你似乎不想要,但最簡單的答案是安裝Firefox 4.如果某些東西不起作用,只需重新安裝3.x即可。您的擴展/設置/等將被保留。


-2
2018-04-04 13:06



那麼,我應該每週都這樣做,直到所有擴展都兼容?這就是為什麼我指定我不想嘗試安裝FF4並看看會發生什麼的原因。 - Rabarberski
您的擴展程序是否實際上不兼容,或者您​​只是因為可能會發生而將您的頭髮從擔心中解脫出來? - Hyppy
感謝您的反饋。我在每個主要的FF版本升級中都有不兼容的擴展,所以我希望現在也會發生同樣的情況。我正在尋找一種我可以在未來重複使用的解決方案。 - Rabarberski