題 鍵盤語言在Windows 10中不斷變化


所以我最近乾淨安裝了Windows 10英文版。我將它配置為使用英語UI語言但挪威語鍵盤。我的設置有幾個問題:

  1. 鍵盤語言不斷切換到英語
  2. 當我交換時,我看不到語言欄或語言切換彈出窗口:

    language toggle popup

我已將挪威語鍵盤佈局綁定到 轉移+Alt鍵+0 這是有效的,但每5分鐘必須這樣做很煩人。此外,我發現在桌面和工具欄上都看不到語言欄我覺得很奇怪。

任何人都知道可能出錯了什麼?

以下是我的設置的一些屏幕截圖:

settings 1

settings 2

settings 3

No language bar on the toolbar

附:我唯一一次看到語言切換彈出窗口實際上就是當我在鎖定屏幕中註銷並按下時 贏得+空間。如果我在登錄後這樣做,沒有任何反應。


240
2017-09-23 06:21


起源


自從我安裝了Windows 10以來,這已經讓我成為了UP THE WALL。鍵盤佈局在我打字時偶爾會切換。我發誓我沒有碰到<kbd> Win </ kbd> + <kbd> Space </ kbd>的快捷方式。 - Colonel Panic
Alt + Shift也會改變它看起來的語言。 - Mir
和 Left Ctrl + Shift 如果安裝了多個鍵盤,則更改鍵盤!! Alt + Shift 和 Ctrl + Shift 是代碼編輯器和Adobe產品(例如Photoshop)中常見的快捷方式模式。 WINDOWS-:這是一個可憐的,不必要的快捷劫持選擇!你太無恥了。哈!不,我不得不繼續“重啟”!我以為這台新的筆記本電腦/鍵盤壞了!感謝大家的解決方案:) - SherylHohman
令我感到遺憾的是,MSFT仍然存在這樣的基本可用性問題。 - Bruno Brant


答案:


在Windows 10中,默認情況下,按 CTRL+轉移 (或某些人 ALT+轉移  - 感謝madmenyo)將循環顯示您可能已映射的任何鍵盤佈局,並且錯誤地執行此操作非常容易。

如果你繼續按下 CTRL+轉移 (或者你可能改變它的任何東西)然後很快你應該回到正確的設置。 (或者重啟,這是我第一次做的;-))

您可以按如下方式禁用此默認鍵盤操作:

Control Panel > Clock, Language, and Region > Language > Advanced settings > Switching input methods > Change language bar hotkeys > Change key sequence... > Switch keyboard layout > Not Assigned

從2016年起,位置發生了變化。 (來自評論)

Control panel > Language > Advanced settings > Switching input methods > Change language bar hot keys 

請注意,以上並不總是有效 - 重啟和睡眠模式都可以改變鍵盤默認設置(通常是美國) - 我發現沒有鑄鐵解決方案雖然創建一個新的配置文件可以幫助,雖然不是一個特別令人滿意的答案恕我直言。

在緊急情況下

WIN+R  
osk

調出屏幕鍵盤可能會暫時有所幫助。

另請注意,可以禁用此功能,以便任何組合鍵都不會更改語言 - 將鍵更改為“未分配” - 請參閱以下Mort的答案以獲取更多信息


321
2017-10-25 22:13



Whaaaat。我在Visual Studio中經常使用Ctrl + Shift。難怪我的鍵盤佈局不斷變化。謝謝! - willem
對我來說這實際上是 ALT+SHIFT - Madmenyo
奇。也許他們改變了這一點,但對我而言,它說切換的快捷方式是[windows key] + [space],這似乎更合理一些(實際上似乎是唯一可以作為語言切換快捷方式的東西)。 - Nyerguds
對於2016年來到這裡的人來說,它的位置似乎已發生變化。現在它位於 Control panel//Language//Advanced settings//Switching input methods//Change language bar hot keys - David Metcalfe
準確地說: win + space 所有配置的語言/鍵盤對之間的更改。 alt + shift 只改變語言和 ctrl + shift 只更改鍵盤 - Simon Zyx


如果單擊上一屏幕截圖中顯示的“更改語言欄熱鍵”鏈接,您應該能夠看到哪些鍵必須更改鍵盤語言。

使用鍵盤時,默認設置很容易被擊中,從而突然改變鍵盤語言。將鍵更改為“未分配”將阻止鍵盤語言意外切換。


15
2017-09-29 10:03



是的,最初設置為Shift + Alt,然後我將它們更改為“none”。不幸的是,這並不是單獨解決問題,而是看到我的另一個答案。 - Nilzor


事實證明我必須在第一個屏幕截圖中配置鍵盤佈局。你會注意到它說“鍵盤:沒有可用”。所以點擊這裡的“選項”,然後“添加輸入法”,然後選擇QWERTY Norwegian解決了這個案例。

我不知道我是如何安裝這種帶有borked語言設置的Windows的。無論如何,我建議大家在初次安裝時更密切地關注語言問題。

Pic1

Pic2


12
2017-09-29 12:50



在嘗試用法語(在加拿大)工作後,我安裝了2個版本的英語(美國,加拿大)和法語(法國,加拿大),更不用說英語美國的多種輸入法。簡而言之,這個答案讓我可以很好地清理所有這些。 - Fuhrmanator


用於禁用鍵盤佈局切換熱鍵的直接註冊表設置是:

reg add "HKCU\Keyboard Layout\Toggle" /v "Layout Hotkey" /d 3

你可能也想要

reg add "HKCU\Keyboard Layout\Toggle" /v "Language Hotkey" /d 3
reg add "HKCU\Keyboard Layout\Toggle" /v "Hotkey" /d 3

對於新用戶,請嘗試此操作(在高架提示符下):

reg load HKEY_USERS\temp "%USERPROFILE%\..\Default\NTUSER.DAT"
reg add "HKEY_USERS\temp\Keyboard Layout\Toggle" /v "Layout Hotkey" /d 3
reg unload HKEY_USERS\temp

9
2018-05-22 14:21



這些命令在做什麼? - kleinfreund
@kleinfreund如第一句中所述,它禁用了切換佈局的鍵盤快捷鍵,因此無法無意中更改它。 - mivk
謝謝!運行內部構建,他們完全從控制面板中刪除了語言部分。我仍然無法理解是什麼導致微軟使用這種常用的鍵組合 - samdd
謝謝!在2018年阻止alt-shift / ctrl-shift切換的唯一方法,似乎你可以改變它的UI組件已經消失,我無法在任何地方找到它。 - jakub.g


2018回答:

我遇到了同樣的問題,嘗試使用波蘭語鍵盤和Windows的英文UI語言。

每次我鎖定電腦,它都會回到美國鍵盤上。

問題是我在波蘭語下使用波蘭語鍵盤,事實上,我真正想要的是英語下的波蘭語鍵盤。

我刪除了波蘭語語言包,在英語下添加了波蘭語鍵盤,並從英語中刪除了美式鍵盤 - 請參閱下面的屏幕截圖:

Windows 10 (2018) language preferences

簡而言之,訣竅是將您想要的鍵盤添加為默認語言下的唯一鍵盤。

(這對我有用,因為我通常輸入英文,有時我只想用波蘭語輸入,但我可以不用更換鍵盤就這樣做,因為波蘭語鍵盤與美國QWERTY完全兼容)。


8
2018-05-14 12:43



哇,我不能說這有助於擺脫幾個月的頭髮拉動(以及低效的工作流程,讓我在編碼時阻止)。令人遺憾的是,他們在Visual Studio(以及大多數圖像/音頻編輯器)中使用Ctrl + Shift鍵梳,並且不知道(或不關心)此類可用性問題。 - Guney Ozsan
這似乎對我不起作用,即使我刪除了 QWERTY 鍵盤,當我關閉並重新打開設置應用程序/重啟我的電腦時將其添加回來。 - Busti
這對我不起作用。儘管只有美國國際,但出於某種原因,輸入每週都會重置給美國。 - Miguel Lomelí
@Busti您是否也嘗試使用管理員帳戶? - Guney Ozsan
我注意到一些Windows更新添加了美國鍵盤,鍵盤語言再次開始更改(使用 Ctrl+Shift)。不幸的是,Windows更新添加的這個新鍵盤沒有出現在語言設置鍵盤列表中(因此您無法將其刪除),但僅出現在語言欄中。要刪除它,您需要將美國鍵盤添加到列表中,然後將其刪除。這將刪除Windows更新添加的不可見鍵盤。 - Guney Ozsan


解決方法1

使用此解決方案 - 如何在Windows 8中禁用自動鍵盤佈局更改? 

溶液2

選擇第二種語言作為默認語言。然後,當你切換到第一個時,它將保持切換狀態。

(感謝@SimonSeyock):

win + space 所有語言/鍵盤對之間的變化。  
alt + shift  只會改變語言  
ctrl + shift 只更改鍵盤


5
2018-03-19 07:13



Solution 1 實際上並沒有提供該鏈接的解決方案。這解決了 輸入法 不是輸入語言。 - msysmilu
alt + shift為我做了。沒有其他真正奏效的 - Ghoti and Chips


我的問題:我安裝了3種語言(鍵盤佈局)。當在Windows 10中睡覺,然後醒來時,它總是默認返回“主要語言”,而不是保持最後一個設置。我認為這是一個錯誤。

解:

  1. 打開 Control Panel\All Control Panel Items\Language
  2. 點擊 Advanced Settings
  3. Switching input methods, 檢查 Let me set a different input method for each app windows

這將在睡覺和回來時保持語言。


5
2018-05-04 03:56



謝謝。這解決了我的問題,鍵盤佈局總是在重啟後和睡眠後變回“默認”。我還安裝了3個鍵盤佈局。英語,因為它適用於一些遊戲和兩個瑞典語。正常的qwerty和dvorak。 - Albert Veli
我有一個類似的問題,通過直接在主語言下定義鍵盤來解決它:請參閱 superuser.com/a/1322521/97570 - jakub.g


這是谷歌的最佳結果 在我的新Windows 10筆記本電腦上工作:

設置默認鍵盤佈局:

  1. 點擊 開始菜單 並選擇 設置
  2. 選擇 時間和語言
  3. 點擊 地區和語言 在左欄中。
  4. 語言 單擊您想要的語言作為默認語言,然後單擊 設為默認

0
2017-12-13 15:20



我會試一試,看看這實際上是否有幫助。有道理+它是我還沒有嘗試過的唯一的東西:) - krizajb
不幸的是,這僅設置默認選項。使用Windows時,它不會阻止鍵盤更改。問題是Ctrl + Shift鍵組合不斷更改所選鍵盤,這在大多數圖像和音頻編輯器中都很常見(以及Visual Studio,嘿,Microsoft,你知道嗎?)。 - Guney Ozsan
我想我在生命中偶然按下了Ctrl + Shift幾次,但除了En-US之外簡單地刪除了所有。您還可以禁用快捷方式: superuser.com/questions/109066/... - Cees Timmerman