題 在tmux下為Vim和Midnight Commander配置PuTTY功能鍵?


首先,我知道我可以使用 Alt鍵+1 (通過9和0)合成各自的功能鍵(F1 通過 F10在午夜指揮官。它曾多次幫助過我,但默認情況下我仍按下 實際 功能鍵直觀。

要點:我正試圖在裡面運行Vim和Midnight Commander tmux 使用PuTTY進行會話(有時是窗口,有時是窗格)。

所以默認情況下我有以下PuTTY配置:

PuTTY keyboard config

ESC[n~ 製圖

映射時的問題(map <F1> :tab help<CR>,並且 nmap 和 imapF1 在Vim中,是它給出了效果  (切換案例)。事實上,如果我按下 F1 通過 F5 在殼中,波浪號(~是結果, 沿 帶鈴鐺。 但是,使用此設置,功能鍵在午夜指揮官中完美運行。

除了我的問題之外,上面的設置有一個奇怪的地方 F1:我也“映射”了 F5 (set pastetoggle=<F5>)在Vim。很奇怪的是  就像一個魅力,儘管如此 F5 shell上的鍵給出了一個 ~ 就像 F1 等等

注意: 在外面運行Vim時 tmux,默認綁定(和我的覆蓋) F1 工作得很好!

用“Linux”映射

所以很自然地我嘗試在上面的對話框中使用“Linux”設置。所以,當我按下 F1 Vim在行尾處進入插入模式(效果為 一個)。 Midnight Commander無法識別具有此設置的任何功能鍵。果然在殼上 F1 給我 A 和一個鈴(F2 一個 B 等等)。

我在這裡想念的是什麼? 如何獲得Midnight Commander和Vim識別功能鍵的統一行為?


附加信息:

遠程系統是Ubuntu 14.04 LANG=en_US.UTF-8

TERM 被設置為 TERM=xterm 在外面 tmux 會話和 TERM=screen 從窗格或窗口內部看時。

我沒有使用:

set-option -g default-terminal "screen-256color"

覆蓋里面的終端類型 tmux


9
2018-05-23 09:54


起源




答案:


問題是 TERM=xterm 外 tmux。有 沒有 與之匹配的PuTTY配置 xterm 終端描述,以及不匹配的信息 screen 要么 tmux (接你的選擇)。

例如,參見ncurses常見問題解答 為什麼不直接使用TERM設置為“xterm”?。那裡的建議當然要設定

TERM=putty

快速檢查使用 tack 表明這種組合(TERM=puttytmux)適用於Ubuntu 14.04(你應該已經安裝了 ncurses-term 包,包括這個)。


5
2018-05-23 19:55



謝謝。其實我找不到 tack 根本沒有 apt-file search 也不是在你推薦的安裝包之後。但 toe -a|grep -i putty 確認存在幾個PuTTY終端定義(包括a putty-256color)。我會嘗試一下並回复你,也會接受。 - 0xC0000022L
我沒有註意到Ubuntu 14.04中沒有大頭釘(它已經在Debian中使用了一段時間,但是當我將它從ncurses源碼tarball中分離出來時可能會被忽略)。檢查我的機器,看起來我正在運行我的一個包。 - Thomas Dickey