題 如何解決VLC的依賴“vlc-nox”?


我安裝了Ubuntu(Ubuntu 2.6.38-11-generic-pae#50-Ubuntu SMP,i686 Athlon i386 GNU / Linux)。我是Linux的新手。

我正在嘗試使用命令行安裝VLC媒體播放器:

% sudo apt-get update
% sudo apt-get install vlc vlc-plugin-pulse mozilla-plugin-vlc

第一個命令執行沒有問題。然後我嘗試運行第二行,它給出了以下輸出:

Reading package lists... Done Building dependency tree        Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies:  mozilla-plugin-vlc : Depends: vlc-nox (= 1.1.9-1ubuntu1.3) but it is not going to be installed  vlc : Depends: vlc-nox (= 1.1.9-1ubuntu1.3) but it is not going to be installed
       Depends: libavcodec52 (>= 4:0.6-1~) but it is not going to be installed or
                libavcodec-extra-52 (>= 4:0.6-1~) but it is not going to be installed
       Depends: libqtgui4 (>= 4:4.5.3) but it is not going to be installed
       Depends: libva-x11-1 but it is not installable
       Depends: libva1 but it is not installable
       Depends: libxcb-keysyms1 (>= 0.3.6) but it is not installable
       Depends: libxcb-randr0 (>= 1.1) but it is not installable
       Depends: libxcb-xv0 (>= 1.2) but it is not installable
       Recommends: vlc-plugin-notify (= 1.1.9-1ubuntu1.3) but it is not going to be installed  vlc-plugin-pulse : Depends: vlc-nox (=
1.1.9-1ubuntu1.3) but it is not going to be installed E: Broken packages

我該如何解決這個問題?

之後我也嘗試安裝 GNOME媒體播放器 來自Ubuntu軟件中心。它返回以下錯誤消息:

The following packages have unmet dependencies:

gnome-media-player: Depends: libatkmm-1.6-1 (>= 2.22.0) but 2.22.5-0ubuntu1 is to be installed
                    Depends: libc6 (>= 2.4) but 2.13-0ubuntu13 is to be installed
                    Depends: libdbus-1-3 (>= 1.0.2) but 1.4.6-1ubuntu6.1 is to be installed
                    Depends: libdbus-glib-1-2 (>= 0.78) but 0.92-0ubuntu1 is to be installed
                    Depends: libgcc1 (>= 1:4.1.1) but 1:4.5.2-8ubuntu4 is to be installed
                    Depends: libgconf2-4 (>= 2.31.1) but 2.32.2-0ubuntu2 is to be installed
                    Depends: libglib2.0-0 (>= 2.12.0) but 2.28.6-0ubuntu1 is to be installed
                    Depends: libglibmm-2.4-1c2a (>= 2.27.3) but 2.28.0-1 is to be installed
                    Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.0) but 0.10.32-1ubuntu5 is to be installed
                    Depends: libgstreamer0.10-0 (>= 0.10.7) but 0.10.32-3ubuntu3.1 is to be installed
                    Depends: libgtk2.0-0 (>= 2.12.0) but 2.24.4-0ubuntu2 is to be installed
                    Depends: libgtkmm-2.4-1c2a (>= 1:2.22.0) but 1:2.24.0-0ubuntu1 is to be installed
                    Depends: libsigc++-2.0-0c2a (>= 2.0.2) but 2.2.4.2-1ubuntu1 is to be installed
                    Depends: libstdc++6 (>= 4.5) but 4.5.2-8ubuntu4 is to be installed
                    Depends: libunique-1.0-0 (>= 1.0.0) but 1.1.6-1.1ubuntu2 is to be installed
                    Depends: libvlc5 (>= 1.1.0) but 1.1.9-1ubuntu1.3 is to be installed
                    Depends: libxine1 (>= 1.1.8-1) but it is not going to be installed

5
2017-10-04 15:40


起源


看起來很混亂......你在運行什麼Ubuntu版本(cat / etc / issue)?您可以嘗試'apt-get check'來檢查包裝系統的一致性。 - guenter


答案:


那裡的日誌告訴你,你錯過了一堆依賴項。您可以選擇單獨安裝或通過空格分隔的慢速路徑。但是,我正在運行ubuntu 11.04(最新穩定版)並且沒有遇到過同樣的問題。唯一的區別可能是我在新安裝後做了(下面)。

sudo apt-get update && sudo apt-get upgrade && sudo apt-get install build-essential

enter image description here

當我去安裝vlc

sudo apt-get install vlc

它告訴我,我需要安裝依賴項。我輸入Y來安裝它們。該過程正常進行並安裝。


2
2017-10-04 16:02



謝謝....現在我能夠安裝vlc播放器...我也去了上層答案。做完後我能夠安裝vlc播放器了。 - prakash.panjwani
是的,你知道你不需要Ubuntu 11來安裝VLC。 - micke
我知道。我只是用我的版本來說明和記錄。 - kobaltz


一些包,比如 gstreamer,不在標準存儲庫中。 您需要從多重宇宙和宇宙回購中啟用下載。

Software soruces window

更多信息: https://help.ubuntu.com/community/Repositories/Ubuntu


2
2017-10-04 16:01





對我來說(Ubuntu 11.10)答案就像跑步一樣簡單:

 sudo apt-get -f install

1
2018-05-20 15:58





我感覺不太好 apt-get升級 其中大部分答案都是建議的。

這主要是因為兩個原因。

答:當不需要升級所有包時,你為什麼要這樣做。

B.並非所有升級包的工作效率都與已安裝的包一樣高效。

我建議使用終端並使用:

sudo apt-get install vlc

現在讓我們說你得到vlc-nox的未滿足的依賴關係

The following packages have unmet dependencies:
 vlc : Depends: vlc-nox (= 2.1.6-0ubuntu14.04.2) but it is not going to be installed
   Depends: libvlccore7 (>= 2.1.0) but it is not going to be installed
   Recommends: vlc-plugin-notify (= 2.1.6-0ubuntu14.04.2) but it is not going to be installed
   Recommends: vlc-plugin-pulse (= 2.1.6-0ubuntu14.04.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

現在只需將依賴項的名稱添加到命令中。

sudo apt-get install vlc vlc-nox

繼續添加依賴項,直到獲得明確的安裝開始。

有一點需要注意:我遇到了一個依賴項的版本問題。 已安裝依賴項但舊版本。

The following packages have unmet dependencies:
 libvlccore7 : Depends: vlc-data (= 2.1.6-0ubuntu14.04.2) but 3.0.0~~git20150319+r59816+33~ubuntu14.04.1 is to be installed

使用清除來解決此類問題。

apt-get purge vlc-data

然後運行install命令。在我的情況下,它最終成為。

sudo apt-get install vlc vlc-data vlc-nox libvlccore7 vlc-plugin-notify vlc-plugin-pulse 

和瞧!希望有所幫助。


1
2018-05-19 12:36





我也遇到了同樣的問題。要解決這個問題我做了

開放軟件中心。

從編輯點擊軟件源

在Ubuntu Software選項卡下,啟用除源代碼之外的所有存儲庫,然後單擊下載

從下載下拉列表中選擇其他

現在點擊選擇最佳服務器

一旦Ubuntu為您選擇最佳服務器,請單擊選擇服務器

現在單擊其他軟件選項卡。

如果找到VLC,請刪除所有條目。然後點擊關閉。

按ALT + CTRL + T組合鍵打開終端並運行以下命令

sudo apt-get clean
sudo apt-get -f install
sudo apt-get update
sudo apt-get upgrade

升級後重啟系統。

重新啟動後再次嘗試安裝VLC。運行以下命令

sudo add-apt-repository ppa:videolan/stable-daily
sudo apt-get update
sudo apt-get install vlc

資源 : - http://computernetworkingnotes.com/ubuntu-12-04-tips-and-tricks/how-to-install-vlc-in-ubuntu.html


0
2017-07-12 03:49