題 iTerm2出現在每個空間上。如何防止它這樣做?


出於某種原因,iTerm2窗口出現在我的每個“太空”(又稱桌面)上。右鍵單擊Dock中的圖標並查看“選項”會顯示“分配給:無”,就像其他所有應用程序一樣。我在iTerm2的設置中找不到任何可以確定此行為的內容。我怎麼能讓它停下來?


4
2017-10-12 07:23


起源




答案:


我也遇到了這個問題,終於找到了。

首選項 - 配置文件 - 窗口和底部有一個可以設置的空格下拉菜單。


17
2018-01-31 14:29



而已!我已經被這一年煩惱了一年了! - duckworthd
問題在於它需要空間,這意味著你不能在兩個顯示器的空間內打開一扇窗戶。 - Pithikos


我一直有這篇文章的絕對相反的問題。我重新啟動了,我的iterm設置將熱鍵窗口設置為每個空格。還有其他人遇到過嗎?

編輯: 事實證明我需要進入dock> iterm>選項>(分配給)所有桌面

我認為這個設置在os更新後重置了。


2
2017-07-05 13:58



感謝那。在過去一年左右的時間裡,我一直很生氣,我的熱鍵窗口一直堅持只停留在第一個空間,每當我把它拉起來時,它都會切換空間。嘗試過多次尋找解決方案,但總是空洞的。這恢復了所需的行為(即熱鍵窗口始終出現在 當前 空間)。非常感謝! - Chris


我不太確定我們是否遇到了同樣的問題。我的問題是:當從iterm2所在的一個桌面(工作區)切換到另一個桌面(我可能想要檢查一些文檔或瀏覽網頁)時,iterm2總是顯示在新桌面之上並覆蓋新桌面上的應用程序。從某種意義上說,每當我想切換到另一個桌面時,我都想要在桌面上使用一些東西(絕對不是iterm2,因為iterm2在我當前的桌面上)或者我只想訪問桌面。當iterm2跟隨時,它只是擰我的意志,我需要手動隱藏或關閉它,當你每天做幾千次切換時,這真的很煩人。

對此的解決方案實際上非常簡單。根據我的觀察,只要iterm2不在應用程序切換列表的第二位(當您使用cmd + tab時顯示的列表),就不會出現惱人的行為。所以我們需要做的是從切換列表中排除iterm2。在外觀選項卡下的iterm2首選項面板中有一個很好的選項可以配置它。

Image of the exclude option

而最底部的複選框就是我們想要的!

我現在剛剛找到了答案,我很高興我終於明白了!自2013年以來我一直很生氣。


0
2018-02-08 07:03