題 在Linux中觀看DVD


我運行Ubuntu 8.10並且許多DVD不會為我播放,我不知道為什麼。我需要在默認安裝之外安裝更多軟件嗎? Totem或Mplayer都不會播放DVD。


4
2017-08-14 15:32


起源




答案:


這在Ubuntu wiki上有詳細記載。

Ubuntu 8.10(i386,amd64)

安裝libdvdread3包(沒有   需要添加第三方存儲庫)   通過Synaptic或命令行:

sudo apt-get install libdvdread3 gstreamer0.10-plugins-ugly

然後打開一個終端窗口   執行:

sudo /usr/share/doc/libdvdread3/install-css.sh

有關其他Ubuntu版本,請參閱Wiki頁面。


13
2017-08-14 15:36



只是為了記錄,如果你使用Jaunty然後你想要libdvdread4而不是libdvdread3。 - nedned
Dan說他正在使用8.10,第二個鏈接提到libdvdread4用於Ubuntu 9.04,jaunty。 - jtimberman


DVD通常是加密的,因此,由於法律原因,Ubuntu Linux不提供解密DVD的軟件包

為了能夠播放加密的DVD,我們需要安裝 * libdvdcss2 / libdvdread4 * 包


3
2017-08-14 15:36





你可以安裝 VLC  - 通常對我來說很好。

或者你可以使用 medibuntu 包裹,雖然它們可能在您居住的國家可能不合法。 以下是使用medibuntu的完整說明。對於播放DVD,關鍵包是 libdvdcss2


1
2017-08-19 15:46





如果您有更新的系統,則已安裝 libdvdcss2 並且還在 Add. Sense: Read of scrambled sector without authentication 在dmesg中,您可能需要為DVD驅動器配置區域。

例如,我的Thinkpad W540沒有配置任何區域,因此在安裝libdvdcss2後它可以播放一些DVD(如Due South),但不能播放其他DVD,例如較新的電影。我花了一段時間才發現它只是在區域編碼的DVD上遇到了麻煩。

無論如何,要解決問題:

# apt-get install regionset

安裝後,運行它以配置您希望能夠讀取區域編碼DVD的區域。您可能需要在驅動器中運行DVD或CD

# regionset

它會顯示當前區域(如果有)並提示您更改它。

我有點懷疑面具。默認值對我有用,但我想知道你是否可以選擇0讓它接受所有區域。有誰知道這是否有效?


1
2018-04-07 01:43