題 無法在cygwin中安裝matplotlib(freetype問題)


在我的cygwin環境中使用matplotlib真的很不錯。我有64位Windows 8和64位cygwin。

當我輸入:

pip install matplotlib

我得到以下錯誤消息:

 * The following required packages can not be built:
 * freetype

根據apt-cyg,我已經安裝了以下軟件包:

Searching for installed packages matching freetype: 
cygwin32-freetype2
freetype2-debuginfo
libfreetype-devel
libfreetype-doc
libfreetype6

還需要什麼?如何正確安裝freetype&matplotlib?


4
2018-06-18 00:25


起源




答案:


我在Windows 7 64位上遇到了同樣的問題;我通過安裝Cygwin軟件包解決了這個問題 pkg-config 和 libX11-devel 在打字之前 easy_install matplotlib==1.1.1 (1.3.1版本在我的機器上有錯誤,因此1.1.1)。


9
2017-07-23 12:24



謝謝你的建議,我會試一試。至於我,我只是在cygwin之外使用matplotlib(正常的Windows安裝)。 - Alexey Petrenko


我在cygwin Windows 8 64位上也遇到了同樣的問題。我在另一個回復中遵循了建議(安裝 pkg-config 和 libX11-devel)但最終允許我安裝matplotlib的包是 libfreetype-devel。然後就是 easy_install matplotlib==1.4.2


3
2017-12-24 16:54