題 Ubuntu 6.06:掛載/ root / sda1 / root失敗:沒有這樣的設備


我們辦公室裡的舊機器,突然運行Ubuntu 6.06無法啟動。我在啟動時收到以下信息:

Uncompressing Linux... Ok Booting the kernel
mount: Mounting /root/sda1 /root failed: No such device
mount: Mounting /root/dev on /dev/.static/dev failed: No such file or directory
mount: Mounting /sys /root/sys failed: No such file or directory
mount: Mounting /pro /root/pro failed: No such file or directory
Target filesystem doesn't have /sbin/init


Busybox v1.01 (debian 1:1.01-4ubuntu3) Built-in shell (ash)

Enter 'help' for a list of built-in commands
/bin/sh: can't access tty; job control turned off
#

據我所知,我沒有改變系統上的任何東西,我運行了一些高清診斷,一切似乎都很好。

谷歌搜索後,我找到了這個帖子: http://ubuntuforums.org/showthread.php?t=246895 這似乎與我的問題非常相似,但是當我嘗試使用以下命令安裝驅動器時:

sudo mount -t ext3 -o rw /dev/hda1 /mnt

我收到以下錯誤:

mount:錯誤的fs類型,糟糕的選項,糟糕   / dev / sda1上的超級塊,缺少代碼   頁面或幫助程序,或其他錯誤   在某些情況下,可以找到有用的信息   syslog - 試試dmesg |尾巴左右

我運行了fdisk -l,它說分區類型是Linux。我真的不知道從哪裡開始,會欣賞和思考。

運行dmesg |後的輸出尾巴 :

[12207.483801] init_special_inode: bogus i_mode (101)
[12207.483809] EXT2-fs: corrupt root inode, run e2fsck
[12260.427078] init_special_inode: bogus i_mode (101)
[12260.427086] EXT2-fs: corrupt root inode, run e2fsck
[13716.998799] e100: eth0 NIC Link is Up 100 Mbps Full Duplex
[13716.998923] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[13727.061967] eth0: no IPv6 routers present
[13896.700449] kjournald starting.  Commit interval 5 seconds
[13896.700458] init_special_inode: bogus i_mode (101)
[13896.700465] EXT3-fs: corrupt root inode, run e2fsck

更新:

運行e2fsck -p / dev / sda1後,我得到以下信息:

/dev/sda1: clean, 142449 / 9584640 files, 5402711 / 19161520 blocks

現在我真的不知道該去哪裡:x

謝謝你的期待


3
2018-01-22 17:38


起源


Ubuntu建議您在輸出中找到其他信息 dmesg | tail 命令,你也可以發布它嗎? - whitequark
是的先生。我會嘗試將它包含在上面。謝謝您的幫助。 - Josh


答案:


你說它是一個較舊的系統......它可能是ext2。


1
2018-01-22 17:50



我用ext2運行它,但不幸的是仍然顯示相同的東西: - /。謝謝你的想法:) - Josh
@Josh沒有後顧之憂...... ooc,重新安裝是不可能的?如果系統上沒有需要恢復的數據,可能更容易重新格式化。 - AJ.
或彈出另一個硬盤並安裝一個較新的Ubuntu或Debian - 如果舊系統驅動器上有任何可恢復的數據,新的系統驅動器應該能夠找到它。 - quack quixote
我實際上嘗試使用最新的Ubuntu Live CD啟動並將驅動器放入另一個系統,但仍然無法安裝驅動器。有關HD的一些重要數據,所以如果可能的話,我想談談。看看我添加到原始問題中的日誌,似乎問題出在Superblock上,這在我看來有點過頭了。從我一直在閱讀的內容來看,我也許能夠恢復它。在我自己嘗試之前尋找更多反饋。 - Josh